TTORA Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
5,583 Posts
Discussion Starter #1
are there fuses or relays or anything that power the trailer lights plugs? I have power going to the plug but when I plug the trailer in the lights wont work. Work fine with the wifes runner and my dads f-250 but not mine. Any ideas? Its like the draw is too much for my truck and I get nothing
 

·
Registered
Joined
·
3,582 Posts
Not that I know of, the only box that I know of for non-factory harnesses is the blinker merger box. Are you getting any lights at all, or is the blinker not working?
 

·
Registered
Joined
·
205 Posts
Spacecwboy said:
are there fuses or relays or anything that power the trailer lights plugs? I have power going to the plug but when I plug the trailer in the lights wont work. Work fine with the wifes runner and my dads f-250 but not mine. Any ideas? Its like the draw is too much for my truck and I get nothing

I don't know if it involves the 03's or not, but there was a recall on the 2000 model for defective trailer harness wiring. Maybe this is your problem??
Bruce
 

·
Row Row Row your Boat
Joined
·
1,632 Posts
check also that the ball and/or the trailer hitch (cup) are not dirty, and that they are getting good contact with each other. I had this problem on my truck and also I had a wire crossed in my harness so the running lights were going to ground and blowing fuses like crazy.
 

·
Premium Member
Joined
·
5,955 Posts
The hitch uses the tail and brake circuits with a trailer harness adapter, usually behind the left tailight, If your rig lights work, then the adapter is FRIED.
 

·
Premium Member
Joined
·
5,583 Posts
Discussion Starter #8
thats just GREAT! Thanks guys.

anyone wanna buy a tacoma?
 
1 - 8 of 8 Posts
Top