TTORA Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
I was wheeling in Moab with my stock height 96 Tacoma over the weekend and was coming off of Moab Rim when I noticed both of my rear (both sides, middle of the three) leafs had snapped. I did some searching and it sounds like this is a common problem. Am I correct in assuming this? About a year and a half ago, I had the exact same thing happen to me on a local trail. I'm getting tired of replacing leafs so can you guys point me in the right direction? I need something that is stock height (no lift). I've been to Wheelersoffroad.com and didn't find much. Thanks for your help
 

·
Registered
Joined
·
1,329 Posts
get some custom alcans, ive never heard of anyone breaking a set of alcans
 

·
Registered
Joined
·
114 Posts
Yes this is a common problem with the '96 models, they had one less leaf. I am going through this myself but I have a 2.5" lift so I am replacing mine with OME Dakkars.
May want to see if you can find a '97 leaf pack, I believe they still fit in length and had 4 main leafs instead of 3. You could also look to see if a local spring shop could replace your leafs and beef your spring pack up with an extra leaf.
 

·
Registered
Joined
·
16 Posts
Yes this is a common problem with the '96 models, they had one less leaf. I am going through this myself but I have a 2.5" lift so I am replacing mine with OME Dakkars.
May want to see if you can find a '97 leaf pack, I believe they still fit in length and had 4 main leafs instead of 3. You could also look to see if a local spring shop could replace your leafs and beef your spring pack up with an extra leaf.
I have a 97 and when I bought it 4 years ago it had a broken leaf, so I wouldnt put all your hope into a 97 leaf pack. To fix mine I took it to a spring shop. They added a leaf on each side and re-arched them too. After I got the bill I wish I would have just gotten some alcan springs or dever springs, they would have been less expensive and better too. If you got a very mild lift (1-2 inches) I think you would be very happy with the setup.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #5 ·
Thanks for the replies. Can anyone else give me some more info on Alcan? I sent them a price quote request and I just want to know if anyone has had any problems with them. I like what I've read so far though.
 

·
Registered
Joined
·
978 Posts
i'm rather impressed you did moab rim in a stock vehicle. .....good job!
 

·
Administrator
95.5 Tacoma
Joined
·
18,525 Posts
I'm getting tired of replacing leafs so can you guys point me in the right direction? I need something that is stock height (no lift). I've been to Wheelersoffroad.com and didn't find much. Thanks for your help
http://www.wheelersoffroad.com/tacoleafs.htm

First item listed. Those are stock height leaf packs. The leafs are made by Deaver and you should never have any issues with them again.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #9 ·

·
Registered
Joined
·
187 Posts
Discussion Starter · #10 ·
get some custom alcans, ive never heard of anyone breaking a set of alcans
Ok, well I DID end up getting some custom Alcans...they broke yesterday. At this point I have had them for a little over a year. I also haven't wheeled with them since July, and I know they weren't broken up until last week when I was doing some other maintenance on the rear end. I know I wasn't being hard on them when they must have broke (I'm assuming they broke on the street), can anyone think of why this would happen (possibly a problem with my shackle setup, which is stock)? This is the third set of springs I have broken. Each time, both sides break. Finally, I haven't talked to Alcan yet, but has anyone had experience with them if they've broken their springs? I'm hoping they'll fix them. Thanks for the input
 

·
Registered
Joined
·
327 Posts
One thing you might be doing is cranking your U bolts for the axle too tight and pinching them, thats a good possibility, or your center pin that holds the pack together was on too tight...basically it sounds like your leafs are bound together too tight not letting them flex and little and are blowing out. :2cents:
 

·
Registered
Joined
·
33 Posts
Shortly after I bought my 95 tacoma in 99 I found out that a leaf spring on both sides were broken. I brought it to the spring shop and was told this was a common problem for tacomas. The only way he knew to help out the issue was to add an extra leaf to the pack but even that would not stop the problem. Since then I have broken almost a leaf a year including the main spring 2 years ago. :( Guess I have learned to live with it.
 

·
Registered
Joined
·
327 Posts
I don't think ubolts or center pins should flex. That's what the bushings at the shackles and hangers are for.
I realize this, but reguardless..you cannot take a impact gun to the shackles and not expect them to bind. they may be over tightened
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #16 ·
3 seats of rear springs on my 96 in twelve years. never fully understood why the 96 Tacoma's broke springs.
Yeah, this will be my third set in about 3.5 years, it's really starting to piss me off...shit, I think I'm just gonna link that crap in the rear haha
 
1 - 16 of 16 Posts
Top