TTORA Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I could use some Beta from anyone that has done more than a few OME installs. I have installed OME 886 and N140S in front and 895/N141 rear.The vehicle is fitted w/ winch and bumper. Here is the problem. When fully unloaded,weight off wheels, the Right side UCA extends down into the coil, making contact, and has torn the upper ball joint boot. Now I know what youre thinking, the spring is not installed right and bowing out, wrong. The spring is perfectly installed and stands straight up. Also in the fully extended position, the lower swaybar link angles outward and contacts the Knuckle.
What I notice is that the Left lower control arms eccentric is adjusted almost all the way out, while the right side is dialed all the way in. I think this issue could be solved if tha lower C arm was ran out like the other one, but there is no way to correct the camber. Everything on the Right side is shifted inward causing binding. I had the truck aligned and all specs are as close as can be , with caster being the only real issue.
 

·
Going John Galt
Joined
·
31,845 Posts
I could use some Beta from anyone that has done more than a few OME installs. I have installed OME 886 and N140S in front and 895/N141 rear.The vehicle is fitted w/ winch and bumper. Here is the problem. When fully unloaded,weight off wheels, the Right side UCA extends down into the coil, making contact, and has torn the upper ball joint boot. Now I know what youre thinking, the spring is not installed right and bowing out, wrong. The spring is perfectly installed and stands straight up. Also in the fully extended position, the lower swaybar link angles outward and contacts the Knuckle.
What I notice is that the Left lower control arms eccentric is adjusted almost all the way out, while the right side is dialed all the way in. I think this issue could be solved if tha lower C arm was ran out like the other one, but there is no way to correct the camber. Everything on the Right side is shifted inward causing binding. I had the truck aligned and all specs are as close as can be , with caster being the only real issue.
detailed pics might help. sounds like something has been installed incorrectly.
 
1 - 2 of 2 Posts
Top