TTORA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
I noticed for the past couple weeks, when I come to a light or stop, I'll sit there for a moment, and the idle will be around 1000 rpm. Then it will suddenly drop to 500 which just seems low to me, the truck shakes alot, and then it comes back up after 5 seconds or so. This all happens with no lights, no ac, no defroster on. Truck is stock 99 taco 2.7 5 speed 4X4. Any ideas whats going on or is this normal. The way it shakes doesnt feel normal to me. It doesnt happen every time I stop though.
 

·
Registered
Joined
·
351 Posts
Jwitc075 said:
I noticed for the past couple weeks, when I come to a light or stop, I'll sit there for a moment, and the idle will be around 1000 rpm. Then it will suddenly drop to 500 which just seems low to me, the truck shakes alot, and then it comes back up after 5 seconds or so. This all happens with no lights, no ac, no defroster on. Truck is stock 99 taco 2.7 5 speed 4X4. Any ideas whats going on or is this normal. The way it shakes doesnt feel normal to me. It doesnt happen every time I stop though.

FWIW, mine idles around 750 rpm and no shaking. Have you ever cleaned your MAF?
 

·
Registered
Joined
·
119 Posts
Just from doing an inordinate amount of searching for a high idle problem, I have seen the same amount of low idle problems. Yours sounds kinda like a vacuum leak or dirty throttle body/isc (iac). Try searching for those and you'll find a bajillion threads.
 
1 - 6 of 6 Posts
Top