TTORA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Honestly, I’ve replace my plugs (and they're properly gapped), cleaned my air filter, and cleaned the throttle body. I have a 97 2.7 and even after doing that stuff to my truck still pings when I’m accelerating from a stop. For the love of god - what else can I do to stop it!
 

·
Registered
Joined
·
279 Posts
Are you sure the truck is pinging and that it isn't just valvetrain noise? The solid lifter OHC is a bit noisy and only gets worse as the cams and lifters wear. You might just need your valves adjusted. How many miles do you have?

Have you checked your timing?

If you're pining due to running lean, you might just need to replace the O2 sensor before the catalytic converter. Other things that can cause a lean condition would be the MAF sensor, the injectors. These would normally come with a check engine light but not always.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4 (Edited)
My yota has 190K on it and runs strong. I've been running 94 in it for the last month and it still knocks. I doubt that my 02 sensor(s) is/are bad because i replaced them 2 years ago. In addition i had my injectors cleaned by the dealership. I've heard that cleaning the MAF might help. As far as the valve clearances go - they sound find. My engine doesn't have the typical "ticking" sound associated with cold start-ups. How can one change the timing? What to do?
 

·
Premium Member
Joined
·
59 Posts
dude are you sure that its pinging? pinging sounds EXACTLY like marbles in a coffee can...you cannot mistake it...
 

·
Registered
Joined
·
67 Posts
4-Bangerfromtheburg said:
Honestly, I’ve replace my plugs (and they're properly gapped), cleaned my air filter, and cleaned the throttle body. I have a 97 2.7 and even after doing that stuff to my truck still pings when I’m accelerating from a stop. For the love of god - what else can I do to stop it!
Blasted ping! I have the 2.7 and it likes to ping up at the top end and also when I start off if I don't give it enough gas. It was bad in the summer especially with the A/C on. I put in a high flow air filter and it helped considerably. Then I went up one tire size and it came back. Now that it is cooler, it has gone away. In the summer I have to run premium fuel to silence it.
 

·
Registered
Joined
·
41 Posts
When I regeared my truck it took most of the ping away but not all of it.
 
1 - 9 of 9 Posts
Top