TTORA Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
473 Posts
Discussion Starter #1 (Edited)
Ok. When I turn my key to the 'on' position, I can hear a buzzing sound (sounds like a pump running) from the engine compartment. It's hard to pinpoint the sound, cause it's down in there somewhere. It doesn't always do it though. If it's not doing it, I can flick the headlights or blinker on, and it will start doing it. If it stays that way for a little while, it doesn't want to start-up. For instance, if I let it buzz for a minute, and try to start up the truck, I can crank on it for a good 30 seconds or so before it will start up. I dont know what the heck the headlights/blinker have to do with the noise starting. I've taken it to Toyota, and of course, they couldn't find the problem. Anybody have any idea what's causing it?
Thanks,
-Dan
________
full melt hash
 

·
Registered
Joined
·
663 Posts
Are you sure it is coming from the engine compartment? Could it be something to do with the fuel pump? :dunno:
 

·
Registered
Joined
·
680 Posts
Your fuel pump is in the fuel tank so that's not it.

Pull the fuse panel cover under the hood and listen for a bad relay or something....

If you can create the buzz at will it shouldn't be too hard to track down with someone to help you...
 

·
Registered
Joined
·
473 Posts
Discussion Starter #5 (Edited)
yeah

It's still under warranty. Will be for a while. I'm thinkin next time I'm just gonna ask if I can get one of the mechanics at Toyota to stand there while I get it to screw up. That way I can be sure they know whats going on.
-Dan
________
glass pipe
 

·
Registered
Joined
·
307 Posts
wierd, mine does that to, thought it was normal...............I have an 04 to. hrm!
 
1 - 7 of 7 Posts
Top