TTORA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
676 Posts
Discussion Starter #1 (Edited)
Okay the past week I've been battling an intermittant problem.... On my half hour commute each way at least once, the truck will throw a fit. It will be missing, in second gear with the pedal to the floor it wont accellerate it'll just shake and sputter....

It's been doing this to the point where i Have to pull over. Where the truck shudders and wont idle, than finally stalls... If I sit a minute and start it back up, I can drive away like it's brand new.... I dont beat it, it's an 01 2.7 4x4 manual.... It has 59000 miles.... about 3000 miles ago I did the thermostat, coolant flush, fresh coolant, cleaned the mass air sensor, the throttle body, ran sea foam through it and put new toyota plugs in it. Been running like a champ till last week.

I got under the hood the other day and checked the coils, hoses, pipes, electrical connections, wiggled wires, all appears well... I havent gone mudding or run through any water. I keep the engine bay clean....

TONIGHT IT did it again, but for the first time it tripped the check engine light. The check engine light was flashing while it was shuddering. Than started running fine and the light went out. It's out now and the truck is running fine. I'm going to try to have the code pulled tomorrow, with obd2 it'll store it till someone clears it right? Thanks fellas
 

·
Registered
Joined
·
369 Posts
Join the club!
I am having massive headach over this shit to. I can not track the problem down. I have check almost everything electrical, and am trying to test the ignightor. but need to find someone who will let me swap them for a few hours/days.
anyways also check your air box. sometimes I have had a masive powerloss and engin stall from a mouce building a nest in the box, the shit suckes into the filter and doesnt alow air in.
Other than that you probaly have a misfire going, pull the code, it could be anything from coils, wires, plugs to the fuckstick problem I have.
Its all odd, a bunch of us here have run into simular problems in the past 6mo. Mine is a 98 with 117K on it and a V6. First I have hurd of this on the 4.
good luck. Let us know what it was
 

·
Registered
Joined
·
369 Posts
Yes, I have 3 coils and 3 wires. I was unshure how many coils you had on the 4.
Good luck. A chilton manule will tell you proper ohms for your model.
 

·
Registered
Joined
·
676 Posts
Discussion Starter #7
yeah I hear ya, it's 4 total coils. They're directly on the plugs, no coil packs or plug wires at all... I took it to autozone, it was "Cylinder 3 misfire detected" I'm going to pull that coil out tomorrow and take a look, as well as check the injector and all acciated wiring....
 

·
Registered
Joined
·
676 Posts
Discussion Starter #8 (Edited)
I filled up at a super shitty gas station, didnt think much of it until today....

Today I made a 60 mile each way interstate trip at 75 mph with the cruise on..... Every time we came to any kind of uphill grade, the cruise had a hard time maintaining speed, it would just shake, and at lights it was stalling and backfiring on it's own..... I burned 3/4 tank of gas in less than 150 miles, where I usually get about 350 miles to a total tank....

Had codes pulled, there were 4
"Cylinder 3 misfire detected"
"Cylinder 2 misfire detected"
"Cylinder 1 misfire detected"
"Multiple Cylinder Misfire Detected"

I'm about to have it towed to toyota, I was with my girl, it was still moving under it's own power, but top speed with stock tires on the interstate was like 75mph, wide open 5th gear....And I'm almost out of gas, I'm like lets get gas and get it home, I'll borrow your car for work tomorrow.... I fill up at chevron.... 5 minutes later back on the interstate the truck is running like a CHAMP... Drove it ALL day today, not a SINGLE hesitation, and it's idling glass smooth and pulling hard as usual.... I had autozone delete the codes to turn the light off and drove 60 miles back home FLAWLESSLY....

Looks like I lucked out and just had a bad tank of gas.... Dont rule that out when you're having problems....
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
3 Participants
Cruznlife1
TTORA Forum
TTORA forum is the best Toyota off-road club around. We are nation wide with chapters in most states. Come in and discuss Tacoma, 4Runner, Highlander, & TRD models.
Full Forum Listing
Top